Workflowy unresponsive
Incident Report for WorkFlowy
Resolved
Workflowy is back.
Posted Sep 15, 2021 - 07:59 PDT
Investigating
We're having a major outage, and are working hard to fix the issue.
Posted Sep 15, 2021 - 06:17 PDT
This incident affected: Web App, iOS App, Android App, and Desktop App.